
Hands-on 1.2 
Manipulation of zebrafish embryos and identification of 

embryonic stages using a bright-field stereomicroscope. 
 

Objective: 

• Learn zebrafish husbandry. 

• Manipulate zebrafish embryos. 

• Identify the different stages of zebrafish embryos. 
 

Materials: 

▪ Male and female adult zebrafish 
▪ Zebrafish tanks 
▪ Breeding tanks 
▪ 90mm petri dishes 
▪ Disposable pipettes 
▪ System water 
▪ Brightfield stereo microscope 
▪ Methylene blue 
▪ 2% Agarose gel plates 
▪ Weight Balance 
▪ Falcon tubes 

 

Solutions and materials preparation 

• 2% Agarose gel plates. 
Weight 2g of agarose and dissolve it in 100mL of ddH2O by heating until the agarose is completely 
dissolved. Pour approximately 15mL of the agarose solution into a 90mm petri dish and allow it to solidify 
for a few minutes. 
 

• Methylene blue 
Weight 10g of methylene blue and dissolve it in 10mL of ddH2O until it is completely dissolved. 

 
 
 
 
 



Methods: 

A) Zebrafish Coupling 
 

1) One day prior to the coupling add males and females adult zebrafish (1:1 ratio) to 
breeding tanks. 

2) Separate males from females by adding a removable plastic partition, allowing zebrafish 
to acclimate overnight. 

3) The next morning, remove the plastic partition to allow fish to couple and breed. 
4) Collect the zebrafish embryos from the bottom of the tank for further manipulation. 

 

 

B) Zebrafish embryo manipulation 
 

1) Collect the zebrafish embryos with the help of disposable pipettes and add them to a 
petri dish - approximately 50 embryos per 30mm petri dish. 

2) Fill the dish with system water containing 0.1% methylene blue. 
3) Using a brightfield stereo microscope, visualize and identify the embryonic stage of the 

embryos. 
  



 
Adapted from Webb et al. CEPP (2007)  

DOI: 10.1111/j.1440-1681.2007.04709.x 

  



 

Hands-on 1.3 
Manipulation of zebrafish larvae and adults: accommodation 

in different settings/plates and exposure to experimental 

compounds 

 

Objective: 

• Learn how to anesthetize, euthanize and manipulate zebrafish larvae and 
adult. 

• Learn how to setup and perform a drug screening testing. 
 

Materials: 

▪ Disposable pipette 
▪ Buckets 
▪ Well-plates 
▪ 90mm petri dish 
▪ pH meter 
▪ Falcon tubes 
▪ Tricaine (MS-222) (compound) 
▪ Weight Balance 
▪ Forceps 

 

Solutions and materials preparation 

▪ Tricaine - MS222  
Weight 400 mg of tricaine powder (Ethyl 3-aminobenzoate methanesulfonate) in 97.9 ml H2O. Add ~2.1 
ml 1 M Tris (pH 9) and adjust pH to 7. To use tricaine as an anesthetic combine the following in a 250 ml 
beaker: 4.2 ml tricaine solution in 100 ml of fish water. 

 

 

 

 



Methods: 

A) Zebrafish Anesthetic 
 

1) To manipulate zebrafish larvae and adults, prepare an anesthetic solution by adding 4.2 
mL of tricaine solution to system water, making a final volume of 100 mL. 

2) Using a net, remove the zebrafish from the tank system and place them in the prepared 
tricaine solution. 

3) Wait for a few minutes until the fish is completely immobilized. Note: Prolonged 
exposure to tricaine can cause death. 

4) Use a net or forceps to remove the fish from the tricaine solution for further 
manipulation or observation. Note: The anesthetic effect should last approximately 5 to 
10 minutes. 

5) After manipulation, transfer the fish to a recovery bucket with system water for 
monitoring for a few hours. 

6) Return the zebrafish to the system tank. 
 

B) Larvae exposure to compounds 
 

1) Using disposable pipettes or a net, collect the desired number of zebrafish larvae and 
place them in the desired plate. Note: We typically use 15-50 larvae per well in a 6-well 
plate. 

2) Remove excess water from the plate and add the testing compound diluted in system 
water, ensuring that it covers the plate. Note: For a 6-well plate, a total volume of 
approximately 7 mL is used. 

3) (Optional) Renew the treatment by aspirating the solution using a disposable pipette 
and adding a new solution. Note: It is recommended to change the solution daily or 
every 2 days to ensure the well-being of the zebrafish. 

4) At the end of the exposure period, anesthetize or euthanize the larvae for further 
analysis. Note: Fish can be euthanized by increasing the concentration and exposure 
time to tricaine. 

  



Hands-on 2.1 
Alizarin red staining of zebrafish larvae and visualization of 

calcified structures and warfarin induced vascular calcification 

 

Objective: 

• Learn how to use water-soluble dyes to detect calcified tissues 

• Use ectopic calcification-inducing drugs to induce ectopic mineralization in zebrafish 

• Visualization and identification of ectopic mineralized tissues. 
 

Materials: 

▪ Warfarin sodium (compound) 
▪ Alizarin red S (compound) 
▪ Tricaine solution 
▪ Bucket 
▪ Fluorescent stereo microscope 
▪ Pipettes 
▪ pH meter 
▪ Fluorescent microscope 
▪ 15 mL falcon tubes 
▪ Tricaine (MS-222) 

 

Solutions and materials preparation 

▪ Warfarin (25mg/L) 

Prepare a stock solution of Warfarin Sodium (25g/L) and dilute it in ddH2O. Add 1mL of Warfarin Sodium 
per 1L of system water. 
 

▪ Alizarin red S (2.5mg/mL) 
Prepare a stock solution of 10mg/mL, diluted in ddH2O and adjust solution to pH 7.4. Dilute ¼ in system 

water for a working concentration of 2.5mg/mL. 

 

 

 



Methods: 

A) Warfarin-inducing ectopic mineralization 
 

1) Prepare fish tanks or individual cups specifically for Warfarin usage. Note: Sodium 
Warfarin can be toxic and should be handled with special care. 

2) Fill the container with system water containing sodium Warfarin (25 mg/L) and add the 
zebrafish. 

3) Change the solution daily for a period of 15 days. 
4) Monitor the well-being and condition of the fish daily and euthanize any potentially sick 

fish. Note: Increased mortality in fish treated with Warfarin is normal. 
5) At the end of the experiment, euthanize the fish and collect them for further analysis. 

 

B) In-vivo analysis of mineralized structures 
 

1) Prepare a container with alizarin red S solution (2.5 mg/mL) and place the fish in it for a 
period of 15 minutes. Note: The incubation period can be adjusted depending on the 
fish's age. 

2) Prepare another container with system water and transfer the stained fish to it for a 5-
minute wash to remove excessive alizarin red S staining. 

3) Repeat the washing process two more times. 
4) Anesthetize or euthanize the fish using Tricaine solution. 
5) Use a fluorescence stereo microscope to visualize calcified structures. Note: Alizarin Red 

S exhibits an intense fluorescence signal when exposed to light at approximately 650 
nm, resulting in absorption at 420 nm. 

  



 

Hands-on 2.2 
Imaging of the opercular bone using a fluorescence 

stereomicroscope. Visualize transgenic fish expressing 

fluorescent markers of different bone proteins 

 

Objective: 

• Identify potential mineralogenic compounds by assessing the 
mineralization of the opercular bone. 

• Manipulate and analyze transgenic fish expressing fluorescent markers of 
interest to assess mineralogenesis. 

 

Materials: 

▪ Fluorescence stereomicroscope 
▪ Alizarin red S (compound) 
▪ Tricaine solution 
▪ Bucket 
▪ Pipettes 
▪ pH meter 
▪ Fluorescent microscope 
▪ Falcon tubes 
▪ Forceps 

 

Methods: 

A) Imaging of the opercular bone 
 

1) Prepare a container with alizarin red S solution (100 mg/L) and place zebrafish larvae in 
it for a period of 15 minutes. 

2) Prepare another container with system water and transfer the stained fish to it for a 5-
minute wash to remove excessive alizarin red S staining. 

3) Repeat the washing process two more times. 



4) Anesthetize the fish using Tricaine solution. 
5) Use a fluorescence stereo microscope to visualize the opercular bone, utilizing the 

fluorescence capabilities of the microscope. 
 

Adapted from Tarasco et al. Comp Biochem Physiol C Toxicol Pharmacol (2017)  

DOI: 10.1016/j.cbpc.2017.04.006. 

 

 

B) Visualize transgenic fish expressing fluorescent markers of different 

bone proteins 

 1) Anesthesize zebrafish larvae and adult using tricaine solution. 

 2) Use a fluorescence stereo microscope to visualize transgenic fish. 

  



Hands on 2.3 

Image analysis and morphometric assessment of zebrafish 

structures 

 

Objective: 

• Learn how to use imageJ software and ZBONE macro. 

• Investigate the mineralization effect of osteogenic compounds. 
 

Materials: 

▪ Computer 
▪ FIJI (or similar software) 
▪ ZFBONE toolset 

 

A) Morphometric analysis of the operculum using FIJI 

1) Download and install Fiji image processing package (https://fiji.sc/) 
2) Download the ZFBONE FIJI-based toolset (https://github.com/MarcoTarasco/ZFBONE) 
3) Open FIJI, go to the "More tools" menu and click on ">>" in the toolbar then select the 

option “ZFBONE”.ZFBONE toolbar will appear in the main FIJI toolbar. 
4) In the case you have an RGB image (Fiji ▸ Image ▸ Color ▸ Split Channels) and work on 

the red channel. (If you save the images in mono-channel there is no need to split 
channels). 

5) In order to enhance the visibility of cranial bones (Fiji ▸ Image ▸ Adjust ▸ 
Brightness/Contrast…). Apply the same parameters to all the images. 

6) Measure the head area (H) and the operculum area (O) with polygon and freehand 
selection tools, respectively. To measure each selection (Fiji ▸ Analyze ▸ Measure) or 
press ctrl+M. 

 

 
 

 

 

 

https://fiji.sc/
https://github.com/MarcoTarasco/ZFBONE


 

Hands-on 3.1 

Exposure of regenerating caudal fin to experimental compounds and 

alizarin red S staining 

 

Objective: 

• Learn how to perform the amputation of the caudal fin. 

• Investigate the effect of compounds in caudal fin regeneration. 
 

Materials: 

▪ 3 mL pipette 
▪ Petri dish 
▪ Forceps 
▪ Scalpel 
▪ pH meter 
▪ 300 mL cup 
▪ 1L cup 
▪ Fluorescent microscope 

 

Solutions and materials preparation: 

▪ Tricaine - MS222  
Weight 400 mg of tricaine powder (Ethyl 3-aminobenzoate methanesulfonate) in 97.9 ml H2O. Add ~2.1 ml 

1 M Tris (pH 9) and adjust pH to 7. To use tricaine as an anesthetic combine the following in a 250 ml 

beaker: 4.2 ml tricaine solution in 100 ml of fish water. 

▪ Alizarin red S (0.1%) 
Dissolve 0.01 g of Alizarin red S in 100 mL of fish water and adjust solution to pH 7.4 with NH4OH. 

 

 

 

 

 



Methods: 

A) Caudal fin amputation and molecules exposure: 
 

1) Anesthetize adult zebrafish (3-4 month) with tricaine (4.2 ml / 100 ml of fish water) 
2) With the help of a forceps, place the fish on top of a petri dish. 
3) Amputation should be performed between the 1st and 2nd segments below the 

amputation plane (consider the first bifurcating rays of both lobes), as in the scheme.  
 

 

 

4) After amputation fish are allowed to recover in fish water.  
5) Expose specimens to the given treatment (either before amputation and/or during 

regeneration) by waterborne exposure or intraperitoneal injection. In the case of 
waterborne exposure, 70% of the treatments is renewed daily.  

6) Allow specimens to regenerate at 33 °C for 5 days. (Recommended fish density: 5 
adults/L) 

 

B) Alizarin red in vivo staining: 
1) Stain fish with alizarin red S (0.01% in system water, pH 7.4) for 15 min 
2) Wash (20 min) and anaesthetize for imaging. 

 

 

C) Visualization and imaging of the caudal fin: 
1) Using a glass petri dish, first place the fish with the head on the left then turn the plate 

and zoom on the regenerated caudal fin. 
2) For each fin, brightfield and fluorescence images are collected sequentially to assess the 

regenerated fin and the mineralized area, respectively. Image are acquired with a 
fluorescent microscope equipped with green light filter (λex = 530–560 nm and λem = 
580 nm). Suggested settings: exposure time 200 ms (brightfield acquisition) and 1 s 
(fluorescent acquisition), gamma 1.00, image format 1376 × 1032 pixels, binning 1 × 1. 
Save images in TIFF.  



 

Hands-on 3.3 

Image analysis and morphometric assessment of new 

bone mineralization and patterning 

 

Materials: 

▪ Fluorescent and brightfield images of zebrafish adult caudal fin 
▪ Computer with the following software installed: ImageJ/FIJI, Excel 

 

Methods: 

 

Image analysis and morphometric assessment: 

1) Open the brightfield image and measure STU (use straight-line selection tool then 
measure; (Fiji ▸ Analyze ▸ Measure) or press ctrl+M) 

2) Measure REG (use polygon selection tool then measure), keep the selection active 
3) Open the correspondent fluorescent image, transform to 8-bit (Fiji ▸ Image ▸ Type ▸ 

8-bit) and restore selection (Fiji ▸ Edit ▸ Selection ▸ Restore Selection) 
4) Select RMA using a threshold ((Fiji ▸ Image ▸ Adjust ▸ Threshold…) then measure 

(ctrl+M) 
5) Close fluorescent image and select the brightfield one 
6) Using a straight-line selection tool, measure the width of each ray before STU 
7) Using any spreadsheet software calculate RAY (average of the rays width before 

amputation) and determine (REG/STU) to evaluate effects on tissue regeneration and 
finally ((RMA/RAY)/(REG/STU)) to assess effects on de novo bone mineralization  

8) Compare ratios of control/vehicle versus treatment/molecule with a statistical software 
 

 


